A Grim North

Musings from a northerner living in the deep south…

Posts Tagged ‘o2’

Snow cycling

Posted by Alan on December 4, 2010

Long Load

No cycling for me during the snow!

With the recent weather, I’ve seen loads of blog posts about cycling in the snow. I did nothing of the sort – not really because of the snow but more because I was busy at Pigs Ear 2010 and the Arcade Fire gig at the O2. However, anecdotally it seems that the snow hasn’t put the borisbikers off in town. Whilst I didn’t have any gloves I wasn’t going to fight that cold wind…

Arcade Fire was quite cool. A good show with some great music but the O2 really is so impersonal and corporate I’m not sure I’d go again. Up in level 4 most people seemed to care more about getting a pint of fizzy piss mass produced lager and a hotdog that in the band. Given how steep the banking and the distance away from the stage that’s hardly surprising. I guess I need to start paying attention to new bands again and get out to the smaller venues…and it was worth setting my expectations low beforehand – having seen Arcade Fire once before I wasn’t too fussed about actually seeing the people!

Glastonbury Sunset

Entirely gratuitous - a shot from Glastonbury 2007 whilst waiting for Arcade Fire

Lastly this week the London Assembly has produced it’s first report on the cycle hire scheme and superhighways.  Called Pedal Power, there’s some serious questions for the Mayor, as well as some general observations – cycle hire works for people as it’s inexpensive and flexible, cycle superhighways doesn’t really work for people as it’s just another bit of paint on the road. Maybe some segregation might work better? Just an idea…

Posted in Cycling, General Meh, Music | Tagged: , , , , , , , , | Leave a Comment »

o2 fail

Posted by Alan on October 4, 2009

Not impressed with the o2 customer service. Last week I did a bit of searching to find out what was happening with the firmware on my N96 – to see when it might be upgraded. Indeed, Nokia have released updates (V20 and now V30!) to the Symbian OS – but o2 customers are stuck on V12! So I thought I would ask o2 when they might get round to releasing their version of the software to receive this garbled reply…

—————————————————–

Good morning Alan

Thanks for emailing us about the Nokia N96. I understand you wish to know when is the firmware upgrade for your phone going to arrive. Also, you’re interested in knowing the realise date for Nokia V30. Let me see what best I can do for you.

Alan, I’m sorry as we’re unable to comment in regards to the firmware software for Nokia N96. I’ve checked the Nokia website and I can’t find any phone named V30 or V20. I’d request you to visit the nearest Nokia store, as they’ll be in a better position to help you with more details about the software and answer your query.

I’d like to tell you that any new phone available with us, it’ll be updated on our website. As there are demands for new phones, I’d request you to kindly keep a tab on our website by clicking on the link given below:

http://www.o2.co.uk/shop/latestoffers

Alan, I’m pleased to tell you that we have a excellent range of other Nokia phones available online. To view the same, please click on the link given below:

http://shop.o2.co.uk/mobile_phones/Pay_Monthly/Nokia

To know more about the best deals available, simply contact our helpful sales team on 08442 020202 between:

– Monday to Friday 8.30am to 9pm

– Saturday and Sunday 10am to 6pm.

They’ll definitely help you with the availability of the phones.

Alan, I realise this isn’t the answer you were looking for. I hope the above information is of some help to you. Have a nice day. If you need any further help, feel free to contact us or visit our excellent online Help Centre at:

http://www.o2.co.uk/help

When you email us please provide: full name, first line of address, postcode, mobile number and registered email address as it helps us answer your query faster.

Kind regards

<name removed>

O2 Customer Service

Posted in Geek Streak, Rant | Tagged: , , , , , | 1 Comment »

Back Online

Posted by Alan on September 16, 2009

I am finally back online. Bloody frustrating this moving house business – I called o2 the week before we moved to try sort things out. But no, we could only organise things once our new line had been activated. Then different departments wouldn’t talk to each other it’s taken until now to get back online.

Apparently my line will support 11Mbps. I’m paying for the up to 8 service – but only getting 6. What’s that all about?

Posted in Geek Streak, Issues | Tagged: , , , | Leave a Comment »